EN RU CN
Wrong Yaw direction with with mavlink control (ardupilot)
  • Hi friends,

    In the past I used the StormBGC for ROI Missions with Mission Planner and Arducopter.

    But I think its time to use alexmos board for this jobs.

    I did a setup with 3 axis gimbal encoder on all axis installed.

    The problem ist, that the yaw axis went in the wrong direction. As I try to test it with the "camera point here" option in mission planner, for example it moves to the right, if it should move to the left.


  • It's definitifly a alexmos problem. I tested it with 4 different gimbals with different configurations.
    3 alexmos 1 Storm32 and only one works as it should (Strom32).

    Also testet it with 3 different arducopter autopilots. Storm32 works, alexmos doesn't

    It would be great to get an reply, Aleksey.
  • Hey, what's wrong?
    Two new fw updates and the problem is still not fixed.
  • Would you mind sharing how you set this up? I'm having a difficult time setting up mavlink. The BGC GUI seems to show serial messages of 0 and 66 but that is about it. Thanks.
  • I could explain how to connect the board 32 bit alexmos to control Mamavlink pixhawk control with the AP and how to set up mission planner. I tried with the manual and I have not been able to connect.
  • Having the exact same problem, have my basecam connected to FC trough mavlink and both Yaw and Roll are reversed.
    It really puzzles me the lack of support and informations on the matter.
  • Hello, guys.

    Thank you for pointing to this problem. As MavLink support still in beta state in our controller, it may contain bugs. I will look into it during this week and issue a version with fix.

    Regarding connection problem, please make a ticket in our helpdesk. Please provide full information about hardware and software versions. Show how you made a connection. Please provide all settings saved to a file from SBGC32 and all parameter exported to a file, from Mission Planner.
  • Mavlink in beta...hmm I changed from storm32 back to BGC32 to get more options regarding to vibrations..Whats with Copter3.4 and BGC32 2.61B2 ?
    I am having issues with the stream rates of some parameters (SR1_Raw e.g.).
    I find nowhere information about the recommended settings for:
    - SR1_RAW_SENS
    - SR1_EXT_STAT
    - SR1_RC_CHAN
    - SR1_RAW_CTRL
    - SR1_POSITION
    - SR1_EXTRA1
    - SR1_EXTRA2
    - SR1_EXTRA3
    - SR1_PARAMS

    These parameters should be given by yours regarding to the things needed for the gimbal.

    Cheers
    Gregor
  • Hello,

    2.61b3 beta has a bugfix for YAW inversion problem.

    I am not sure that SR1_XX parameters affect data rates that relate to SBGC32 connection. To receive all streams, command REQUEST_DATA_STREAM is sent, where required data rate is specified. In my test setup, the following values are set: http://ybex.com/d/nzl0nbu7h33zroe4c5xhgklwrevivkpu9s8hfnsv.html
    (guess it's default values).
  • I just tested a case when gimbal controller starts with a delay 15-30 seconds after PX4. In this case, required data streams do not come to SBGC32. I don't know the reason why Ardupilot does not process REQUEST_DATA_STREM message correctly in this case. But setting data rates manually from MissionPlanner helps. The following values should be configured:

    SR1_EXTRA1=20
    SR1_POSITION=5
    SR1_RC_CHAN=20

    all other SR1_xx may be set to 0.

    If SBGC32 is connected to the port other than Serial1, set SRx_xx parameters for this port.
  • Is it mandatory to set this parameter to these values and set the remaining to zero? Can we have some documentation or we just have to trial and error on this mavlink connection thing?
  • In the message above I wrote that it works without setting these values in my setup. But under some conditions they are required.

    MavLink configuration is described in the User Manual, section "Connecting to Flight Controller by the MavLink protocol". http://www.basecamelectronics.com/files/v3/SimpleBGC_32bit_manual_2_6x_eng.pdf
  • Hi!!
    I try to set up mavlink connection between a pixhawk under 3.4 and a HDair studio MSR360 (best gimbal ever). I want to connect the telemetry port to the gimbal (with encoders). Am I obliged to go with RC_Yaw and AUX3? I'd like to connect it via UART connector, wich is free in the MSR360. Is it possible? Could you make a mapping guide for this config, if it works for now?

    Thank you,

    Julien
  • Hello, Julien
    MavLink may be configured on any of available UART ports. There is may be hard to understand where which port is routed, in few words, UART1 - normally parallel to USB, RC_SERIAL - RC_ROLL (Rx), RC_YAW (Tx), but may be swapped to AUX3 (Rx) if parameter "Swap RC_SERIAL - UART2" is enabled in the GUI (by default it is enabled for the encoder firmware, but can be disabled in the latest versions of firmware), also it's available UART2 - Aux3 (Rx only), if set "Enable UART2" option.