EN RU CN
Airframe/ gimbal yaw axis keeps spinning on multirotor with tripod landing gear - how to lock z-axis
  • Hello,

    Would be great if I could receive some help here on something I just can't get solved.

    I am using the SimpleBGC 32-bit board with the 2.56b7 firmware, on a hexacopter.
    It is installed on a 3-axis BL gimbal, similar to a Cinestar setup: with a tripod landing gear, attached below the airframe and rotating around the yaw axis.
    Total take off mass is 5kg, with a light DSLR or similar installed.

    All axiss are tuned and working well - as long as the airframe is suspended on a rack or in the air.

    The problem I have is on the ground, before take-off:
    As the tripod landing gear statically sits on the ground, the upper/ airframe part slowly spins freely around the z-axis or lightly oscillates (at least while the props are not rotating yet).

    This behavior makes proper pre-flight calibration of the FC and a "sane" take-off sketchy.

    I would like the Yaw -motor to simply "statically" hold tight and lock the gimbal z-axis to the airframe position in this phase. With simply the flick of a switch on the camera RC.
    (Freefly calls this airborne lock mode, with motors on and holding steady)

    But I don't know how to configure the Basecam gimbal controller to do just that.

    The workarounds I can think of might be to take off and land:
    a) with the gimbal motors off altogether.
    (But I don't like the idea of camera gear just flopping around in this phase)
    b) with a secondary setting selected through the command switch, where the Yaw motor input is disabled, and later activated by choosing a second setting in flight.
    (But this let's the airframe still rotate freely as well)

    Neither of the workaround are desirable - I simply want the yaw axis to positively "lock".

    I thought of drastically raising PID values to possibly clench things down. But I think this will just end up in oscillation - it seems like the Alta is battling that: http://forum.freeflysystems.com/index.php?threads/spinning-alta.7390/

    I am using a power setting of 200, and have Follow disabled. I thought first that checking "Follow Yaw" might help, but it does not seem to.

    So what can be done to resolve this?
    Thank you,
    camti
  • You could try to set 'I' 0.0 on PID. Also try Outer PI on advanced. Also above yaw IMU could help, but probably not and maybe follow mode. Just Ideas what you could try, I have not tried these.

    In theory also feedback from yaw position like on the potentiometer modification could help. http://www.rcgroups.com/forums/showthread.php?t=2243241

  • Thanks for the hints.
    PID value "I" to zero does stop the rotation. But, while there is no spinning now, there is no hold either - no positive lock as I would want.

    The documentation of the Outer PID values in the manual is very slim, can't figure out what to do there.
    Adding a potentiometer is not an options, as there are cable going through.

    Has anybody encountered and succesfully tackled this particular problem?
  • I'm just starting out with this and have the same problem. I haven't even mounted my gimbal on my MR yet. It spins very slowly on the stand. I still have a ways to go, need to calibrate my IMU redo my PID settings and better understand some of the tabs on the GUI but hope to get there soon.
  • I still have not been able to accomplish the "hold" setting, which makes a reliable calibration before takeoff difficult.
    If anybody has the solution how to implement this in the given configuration I would be grateful to find out from them.
  • hello guys, i have a cinestar cs8 and just now i'm upgrading to yaw, i have the same problem, if you have any solution please share it. I' have seen that if i start in follow mode the yaw don' t spin only oscilates more o less quickly depending of the speed amount in follow mode tab. I will try.
  • YOU need to compleet PID tuning on YAW axis
  • FWIW, my Yaw axis IS properly tuned, and does not display this behavior as long as the airframe is suspended and held tightly, and the gimbal can move freely. The "oscillation"/ freewheeling problem occurs when the tripod landing gear is standing fixed on the ground, and the airframe above it can move.

    Having a separate profile with a I-value of zero is a work-around for take-off/ landing - yet I'd much prefer a solid "hold" in this phase, and to get a proper calibration.

    If somebody has solved this, I'd be glad to know.
  • yes this is a common issue your yaw is not tuned properly! suspend the copter from a rope or between 2 chairs and tune the copter properly. the trick is to have no pressure on the yaw like it would be in the air the. Things to keep in mind transmitter may cause this because it is off center or one channel that is not centered properly. makes no sense to rotate on the ground not rotate in the air
  • Maybe I am not quite following you. What do you mean by "no pressure on the yaw"? There will still be wind-pressure and rotor-wash on the gimbal that the Z-axis has to compensate forcefully, right?

    As mentioned, if I have the entire rig suspended as you describe (simulating the airborne state), things operate as expected. The issue I have seems to also be encountered by the Alta (see link in my post further up).