EN RU CN
Just installed a brand new Controller , have a few questions
  • I just installed a brand new controller and calibrated everything. Now I have two issues.

    1) My yaw won't follow correctly

    2) My blutooth won't connect to gui yet it connects to my computer.

    Thoughts, suggestions? Anything will help and I appreciate all the help

    -Kareem
  • what'is the firmware? 32bit?
  • Is the bluetooth correctly connected, verify Tx to rx and rx to tx.
  • 32 bit and everything is up to date.
  • I know this is an old topic but I am replying to this as I have just wasted a day trying to get the Android GUI and Linux GUI to connect to the controller via HC-06 Bluetooth module.

    I have a ArrisCM3000 with a 32Bit Basecam V3.0 HW board running 2.56B9 SW


    Most likely your Bluetooth module is set for 9600 baud from the factory.
    To prove it, do the following:

    1) Connect to the controller via USB and select "Connect" to start the comms.
    2) Select "Advanced" Tab -> "Serial port speed" to 9600.
    3) Write the settings to the controller.
    4) You will have to cycle the power to the controller and restart the GUI.

    5) Reconnect to the controller via the USB to confirm you have comms at 9600.
    The update rate will be poor but it is usable.

    6) Attempt to connect to the controller via the Bluetooth module. You should get a connection.

    Now that you have proven the problem, you can correct it by following this link:

    http://smarpl.com/content/bluetooth-module-hc04hc06-configuration-tool

    This guy has put together a simple tool to configure the Bluetooth settings via the command line.

    Only issue is that the Bluetooth module has a TTL serial interface. You need a FTDI USB to Serial board to interface it to your PC. Sparkfun as a number of these units.

    1) Use the config tool the set the baud to 115200.
    2) Reconnect to the controller via USB and change the "Serial port speed" to 115200.
    3) Cycle power and everything should work well over Bluetooth.








  • Still no luck with that