EN RU CN
Bluetooth connects to computer but not to GUi
  • Suggestions on how to fix this problem

    -Kareem
  • If You have bluetooth bought and not configured it is likelly a baud rate. Bluetooth modules comes with default baud 9600 but alexmos software is configured to baud 115 600 or something like that. You can reprogram bluetooth module or connect via able to the board and change baud to baud that Your bluetooth is configured and all should start to work. If this is a problem
  • also make sure it is connected correctly, pay attention to tx and rx http://www.basecamelectronics.com/files/v3/SimpleBGC_32bit_Bluetooth_Connection.pdf
  • Swap only data cables of Bluetooth modules end enjoy.
    I had the same problem ! :))))
  • The board is labeled different than the bt module. Is the basecam board labeled wrong?
  • I know this is an old topic but I am replying to this as I have just wasted a day trying to get the Android GUI and Linux GUI to connect to the controller via HC-06 Bluetooth module.

    I have a ArrisCM3000 with a 32Bit Basecam V3.0 HW board running 2.56B9 SW


    Most likely your Bluetooth module is set for 9600 baud from the factory.
    To prove it, do the following:

    1) Connect to the controller via USB and select "Connect" to start the comms.
    2) Select "Advanced" Tab -> "Serial port speed" to 9600.
    3) Write the settings to the controller.
    4) You will have to cycle the power to the controller and restart the GUI.

    5) Reconnect to the controller via the USB to confirm you have comms at 9600.
    The update rate will be poor but it is usable.

    6) Attempt to connect to the controller via the Bluetooth module. You should get a connection.

    Now that you have proven the problem, you can correct it by following this link:

    http://smarpl.com/content/bluetooth-module-hc04hc06-configuration-tool

    This guy has put together a simple tool to configure the Bluetooth settings via the command line.

    Only issue is that the Bluetooth module has a TTL serial interface. You need a FTDI USB to Serial board to interface it to your PC. Sparkfun as a number of these units.

    1) Use the config tool the set the baud to 115200.
    2) Reconnect to the controller via USB and change the "Serial port speed" to 115200.
    3) Cycle power and everything should work well over Bluetooth.