EN RU CN
Blue Acceleromoter axis stuck in the IMU calibration helper
  • For some reason, no matter how it moves the onboard IMU 1 accelleromoter axis seems to be stuck. It never changes. Which means I can't use that IMU. Anybody else have this problem or have a solution.

    I have tried resetting it and I have tried reflashing the firmware. Reflashing the firmware gives me this error: "Error writing firmware: [74] No DFU capable USB device available", and the board makes a whining sound.

    32 bit basecam tiny.
  • I am getting the same problem.. my Camera IMU is not working. Does the main SimpleBGC Board (PCB) act like it is the camera IMU.. so if you move the main Simplebgc board and not the Camera IMU it shows movement in all axis.. Basically is sounds like you are having a very similar problem as me.. my camera IMU is not being detected although I tried the Camera IMU on my other SimpleBGC and it is working fine.. so I know it is a faulty board.. sucks too because basecam will probably not exchange my board for a new one..
  • Is it original IMU that came with the board? Not all IMUs work with all boards.

  • The GUI picks up both of the IMUs. The problem is that the z-axis of the acceleromter of the onboard IMU doesn't work at all. It stays at the same value. I got it from Flyduino. Don't buy stuff from them. Their customer service is pathetic.
  • It is the IMU that came with the board because it is an onboard one. So I can't even replace it now.
  • If the Z axis is not working, then it is broken. I have seen some instructions how to remove the onboard IMU (requires removing couple of resistors on board , but do not remember where the instructions are) When it is removed, then external frame IMU can be used. But maybe you should still contact the seller.

    With original IMU I meant the camera IMU.