EN RU CN
Basecam Electronics board from Turboace - cannot connect
  • I have purchased a Matrix-S quadcopter kit from Turboace. Horrible experience as there is no documentation that came with this 3 axis gimbal. No data on motors, board etc. I had to figure out after researching online that this board labelled bascam electronics with what looks like a piggy back mini board attached to it for the yaw axis is a chinese imitation? Or am I mistaken.

    I had originally 2.4b6 installed on the board which it came with, then I tried upgrading firmware to 2.5 and it said it successfully updated firmware. However, consequent connections to it via usb was not seeing the board.

    It flashed green 3 times when I plug in USB. Also the COM6 (on my machine) virtual port shows up. The light is solid red on the board with a solid green light on the other glued together piece.

    I have seen someone on here go through details of how to recover the firmware by shorting the flash pins. Mine doesnt have ANY flash pins, at least I dont see FLASH marked on the board anywhere?! Can someone please help me figure this out. I called a couple of local RC stores and this guy was rather rude saying they dont want to know anything about stuff they cant carry. Anyway, I was trying to get the board firmware updated bc the camera was going crazy even after 2 days of getting sensor calibrated and messing with PID settings. It worked for a while then just started going nuts (the YAW especially)

    Anyone please let me know what I can do to fix this.

    Thanks!
  • Hello,
    Please, take photos of both sides of your board in high resolution and place here.