EN RU CN
Firmware upgrade problem
  • Hi!

    I have the following problem:

    I have 32bit board that initially had 2.50b2 firmware. It gave me some sporadic errors while writing settings into the board. I've decided to upgrade it to the latest 2.50b3. Tried to check current OTA firmware - it said: Error checking latest version:java.lang.exception: Error sending HTTP request: javax.net.ssl.SSLHANDSHAKEEXCEPTION.... Therefore, I've decided to manually update the board. I went to recovery option, chose 2.50b3 recovery hex and pressed FLASH. GUI reported that firmware flashed sucessfully. I've tried to connect to GUI but no luck. It says 0.00 board version and board is continuously beeping.

    I've followed instructions, put a jumper on FLASH pins, powered up the board from USB, selected 2.50b3 recovery hex and flashed without connecting to the board in GUI. GUI reported that board is flashed sucesfully. Powered off, removed jumper, powered on, tried to connect to GUI - no luck. It still says 0.00 in board version. Tried to do the same procedure for 2.40b6, 2.50b2 - no luck either.

    Now I am stuck at this. Is there any possibility to bring this board to life again?
  • Friend do not feel alone in this problem, I also suffer. Hopefully the technical service of a solution we are very competent;-)
  • Did you try normal FW update after the recovery?
  • Already solved the problem.

    The problem in my case was that I didn't even try to flash normal firmware right after recovery firmware due to two reasons:

    - GUI 0.00 b0 reading is misleading and I didn't understand first that I have to ignore it and write usual firmware.

    - when I've checked for the OTA firmware - I had an error that has to do with java certificate. So, I had no chance even to try to write usual firmware because of that.

    I took another PC, downloaded GUI, connected the board, got GUI showing board 00.0. b0, went to firmware check, got a notification that there is 2.50b2 awailable, pressed FLASH and voila - it is done and working now.... So, the problem was that my PC just didn't want to communicate with the server.

    Anyway, if there is 2.50b3 available already, why does OTA says that the latest is 2.50b2?
  • You know you because your previous computer would not connect to the server? I do not have a second computer and can not solve the problem. Thank You