EN RU CN
Virtual channels not assigned correctly
  • Hi all,

    I'm having an issue using the virtual channels which correspond to the Sbus connection on my Frsky X8R reciever.

    When I setup my Taranis Tx model to use channels 17-32, I would expect that I should then access those channels using the same numbers in the Basecam gui in the remote tab. However, in order to get the input of, say channel 17 on the Tx, I have found that I need to use virtual channel 1 in the GUI. And channel 18 gets mapped to virt channel 2, and so on.

    What am I doing wrong here?
  • Taranis seems to be 16 channels normally, do you have the "up to 32 channels (dual module (RF systems))" But even then I would guess that both transmitters send 16 channel at their own frequencies.
  • I'm using an external RF, the FrSky XJT module, for an additional 16 channels. Sorry that I was unclear about that, I've come to terms with the 16 channel offset in the Basecam GUI software after several have told me that's just the way that software works. Fact is, it doesn't really make a difference, just isn't as tidy or intuitive as I'd like, but in the end does the job,
  • I do not think it is a offset in Basecam. SBUS and Spectrum works 1 to 1 on my systems.

    I think the Tarantis has two transmitters that both send channels 1 to 16 at different frequencies.

    I think 17 to 32 is Tarantis internal mapping for the second transmitter 1 to 16.

    Anyway, the main thing is that it works.
  • You are exactly correct. Just needed to wrap head around it.