EN RU CN
Follow and RC movement
  • Hi, all.

    I'm having some strange behavior in my yaw axis when mixing follow mode and RC. My board is 1.0 8-bit 2.40 b7.

    I usually use RC to move yaw in both normal and follow mode (when needed), and it works fine: fast, smooth and precise. Trying to avoid some small and undesired movements I noticed from yaw in follow, I started setting accurately deadband (originally at 5) and expo curve (originally at 0).

    The problem is, when I move the yaw with RC, it doesn't stop in a very near angle from where the stick reached the neutral position, like before, but it weirdly goes backwards several degrees.

    I want to use RC to move the yaw when in follow because there are some moments, like in flight, when the angle can't be manually corrected when needed. For this purpose the problem shouldn't bother much, but it really does since the movement gets very stuttery and not very precise.

    I noticed there are two Speed parameters for each axis, one in RC tab and the other in the Follow mode window. Setting at 0 the follow speed seems to solve the problem, but then Follow mode remains useless as the camera stays in the same angle, just as the normal mode works. So I'm guessing both Speed values should be set higher to 0 for RC and Follow both to work at the same time. Resetting deadband and expo curve values also don't make any difference.

    I don't know what could've gone wrong in the process of setting deadband and expo curve, I need to investigate and test more. But I would like to know, theoretically could Follow mode be mixed with RC commands without any problems? Could the expo curve effects be somewhat causing this behaviour?

    LPF and I parameter don't seem to affect the problem in a notable way, either, positively or negatively. I know I'm missing something...

    Thanks a lot.
  • Sure, follow and RC work at the same time.

    LPF affects a lot, at least on 32 bit, do not remember on 8 bit, but I think it affects on it too. Set LPF to 3, and higher only if needed. High values cause slow response and overshooting.

    Expo will not cause anything strange, just what it does, unlined response according the expo curve.
  • But are they both supposed to work fine when the two Speeds are set higher than 0? I mean, can you guys do it without problems?

    I had LPF at 3, tested with other values, and I ended leaving it at 3.

    I spent like three hours today testing practically every setting in 2.40 b7. As soon as I set Follow mode's Speed higher than 0, the problem appears, and can't get rid of it. RC Settings' Speed is 20, and it seems to work fine always with my gimbal; lower values, no change. Deadband and Expo curve apparently don't have any effect on the behavior, either.

    The gimbal returns the same way at some point when the stick is returning to neutral. The red dot doesn't keep the position, it goes backwards some range. Most of the time occurs, sometimes it doesn't. It gets worse when doing fast movements, but it can show even going very slowly. It's like at some point the system behaves like Angle mode, or like the yaw is trying to reach some angle that shouldn't be taken as reference since it's Follow mode... Very weird.

    Maybe it's some firmware bug?
  • I doubt it would be any FW bug. sounds like very common functionality you are having problems with and 2.40b7 has been out long.

    I am somewhat unclear though what the problem exactly is? Though it is long time since I have used 8 bit, I have always used joystick with follow and had no problems. the Speed of the other does not affect the other.

    Are you sure your basic setup is ok, wrong motor inverted can cause strange issues, or wrong pole numbers.
  • Those parameters in Basic tab are fine, I believe, since I knew they're important and don't usually touch them. Again, “normal” mode still works perfectly...

    The problem is certainly weird, because Follow mode's Speed is apparently only used for the camera to move when Follow mode's Deadband (and Expo curve) is higher than 0... It shouldn't affect the axis in such way, nor the RC performance; but somehow it does, indeed.

    Do you have any ideas?

    Thank you.
  • I have hard time understanding how you have configured it and what the problem is. Could you post the Folow and RC tab pictures.

    Btw, it is not long time since I had wrong inverted in basic tab, and was banging my head to wall long time before realizing that. In fact I had 2 inverted wrong and it still worked mostly ok. Best to verify the settings. (motor auto and correct pole-count after)

  • As requested, the firmware configuration when the problem appears:

    http://s14.postimg.org/whh7kj7v5/2015_06_15_Follow_mode.png

    http://s28.postimg.org/c04xtd9gt/2015_06_15_RC_settings.png

    I redid the Auto, none of the three motors are inverted. Poles are 22, checked in the motors specifications (Auto gives some weird values sometimes, at least for yaw).

    The problem is, the red dot should stop as soon as I start to release or move back the radio stick. But the red dot stops and then goes back some range to the side it came. Therefore, the yaw goes to the desired direction, but when you want it to stop, it goes backwards some way.

    Also, the movement isn't as continuous and fluid as when I set Follow yaw Speed to 0, or when I disable Follow.

    Any advice?

    Thank you.
  • You have much limited the RC yaw movement. Unless you specially want to limit them, set them much higher. I am not sure about 8 bit, on 32bit setting them to 0 removes the limits.

    Follow speed is very slow.
  • I tested, and more follow speed didn't seem to help. But I need to test more.

    Precisely, a question I wanted to ask for some time is if min. angle and max. angle in RC is OK at -45 and 45 to move it 360°, or rather without limitation. It has always been -45 and 45, and seemed to work fine. I'll definitely try 0. If 0 doesn't work properly, what angles should I set?

    Thanks a lot.
  • If 0 does not work, just set an angle that does not limit the movement. I used some +- 400 degrees.
  • Another strange behaviour I noticed is yaw offset seems to change every time.

    When I set a value for yaw offset in follow for the yaw and the rest of the gimbal and the camera to point exactly forward, then move the gimbal around and then leave it still, the yaw can't be positioned anymore to that precise angle where everything is aligned, unless I change again yaw offset.

    Why the offset changes? How could I solve that? So far, nothing worked: I = 0, I > 0, speed = 0, speed > 0...
  • The yaw offset affects the startup point only. the gimbal must be close to correct position, if the motor goes one pole over then there will be that much yaw error. Non encoder gimbals have no true yaw reference.
  • OK, thanks a lot for the useful info. I think I'll leave yaw offset to 0, then.
  • Now follow yaw RC movement seems to be working perfectly as before (and as nonfollow profile), even when I set some yaw expo curve value, and follow yaw speed. I don't exactly know which change got it to work back properly, setting the correct number of poles for yaw, changing the PID values or what, but in this aspect I'm happy with it as it is now.

    Yaw offset apparently is OK at 0. Oddly, now the yaw usually returns slowly to a more precise angle and it gets to point forward (helped by hand, if needed), it doesn't remain locked in some deviated motor steps even with offset and I at 0. Maybe the yaw number of poles value change could have something to do here, as well.

    I think the only undesirable behaviour that remains now is something that happened always, but lately, looking for a nice handheld stabilization and using Deadband and Expo curve, it's more obvious and annoying, and makes handheld work harder and slower. When I rotate the yaw to make a normal (not even fast...) pan movement, the axis sometimes keeps pointing to that direction and therefore it remains seriously deviated, and one can't make it return to the correct forward position unless using RC or by hand. I think it's not like the motor loses steps, it's more like the yaw loses the “initial” angle and then the Deadband range works in a side instead of the actual “0 angle”, so to speak. What could be causing this behaviour, and how could I try to correct it?
  • I would suggest using small deadband and big expo.

    The problem with dedband is that when the deadband area ends, the movement starts suddenly, and it is difficult to know where it ends.

    If you have 32 bit board, newest beta FW have some deadband centering settings.