EN RU CN
What up with the ROLL (X axis) not holding level?
  • Dear members, I am in desperate need of your help, i have built myself a 3 axis DSLR gimbal using Alexmos SimpleBGC 8Bit board. I have been torturing myself for weeks now to figure out what seems to be the problem but in vein i just cant fix it. The roll (X) is always rolling to certain degree (about 15 degrees) when i move in "Z" axis, to be specific if i move clockwise in "Z" axis, the camera would go about 15° tilted to the right in "X" axis & if i move Anti clockwise in "Z" axis, the camera would go about 15° tilted to the left in "X" axis. in both the cases the roll returns to the position parallel to the ground but very slowly. Most interesting thing is this case is that the roll "X" axis of the gimbal is not parallel to the Horizon but in SimpleBGC GUI software the ROLL shows completely parallel to the horizon. At first i thought i might have a faulty IMU, so i replaced it & the problem persists, I tried ACC calib using the bubble cube about 20 times but no results. I know i am wrong somewhere but just cant figure out.
    I will deeply appreciate your effort to help me.

    Best Regards,
    Bluebird
  • Hello,
    Please, make a photo of whole your gimbal and place where you mount IMU sensor. And place photos here.
  • Hiya - I've been having the exact same issue for weeks now - horizon drift in the direction of travel. I've tried every setting change to no effect. Very frustrating. I was just wondering if you had found any solution? Thanks - Matt
  • having the same problem

    someone help....
  • Sometimes it is best to erase the EEPROM and do everything carefully again from start. Doing this has always helped me. There could be something it remembers form old FW etc. or something wrong with the basic setup. ( I have had both, though I am experienced with Basecam, errors on basic setup happen! and best way to find them is to do the complete setup again.)

    My advise after Erase EEPROM it to first go to RC menu and set everything not connected (even if something would be connected) and check the 'skip the calibration at startup'

    then perform the basic setup carefully and completely. If the old Power and PID values where working I use them, and copy them manually as first step, then perform calibration, motor auto, correct poles etc.

    When everything is working, set RC, Follow etc. not before.

    Note, before you erase EEPROM, save it and save also profiles. This way you can also always go back. I usually take also a screen shot of the PID values.

    Note2, always after FW update and erase EEPROM power down completely (Battery and USB disconected) and make sure FW and GUI number correspond when restarting. always use correct GUI.