EN RU CN
Firmware Update Timed-out - Can't connect to GUI anymore.
  • So its been awhile since I updated my controller so I thought i'd do it today as the weathers getting better here in the UK.

    I run a Desire RC Alex Mos V3 (32bit) http://www.desirerc.co.uk/index.php?option=com_jcommerce&pgn=product_info&products_id=114
    It's bluetooth only which isn't an issue for me as my Mac has a bluetooth module built in.

    I downloaded the latest manual and GUI as it seems to be updated fairly regularly.

    I did the usual process, connected the battery to the controller, paired the device to my laptop, and press connect on in the GUI. It told me that my firmware was out of date which I expected. I went to the upgrade tab, It said I was on 2.43 I believe. And the latest was 2.50b3. Changed the version in the drop down to 2.50b3 and hit upgrade. Out of curiosity I clicked the details button on the progress bar. Everything looked normal. Then I get a message saying firmware update timed out or something along those lines. The controller had been disconnected from the GUI. When I tried to connect again it wouldn't let me, just keeps saying connecting. The gimbal no longer functions either, the motors are powered off.

    Anyone got any ideas what to do next please? A manual update procedure?

    Thanks in advance.
  • Heres the output from the details view when doing the firmware update

    Pausing monitoring..
    Signing request..
    Entering boot mode...
    Waiting for bootloader to start...
    Downloading firmware...
    Downloading firmware...
    Writing data into file "/Users/oliverevans/Downloads/SimpleBGC_GUI_2_50b3/firmware/simplebgc30_v2_50_b2_01235e2ea930728cee.bin"...
    Firmware is downloaded: 131072 bytes
    Writing firmware...
    Writing firmware...
    Found bootloader version: 3.1
    Chip ID: 0422
    Starting Extended Erase of FLASH memory. This will take some time ... Please be patient ...
    Extended Erased FLASH memory.
    Programming flash ...
    Process finished.
    Error upgrading firmware: Error writing firmware: Timeout!
  • I managed to flash the controller and I am now successfully able to connect to the GUI, but when I continue through the upgrade process, I get the same errors as above :(

    http://imgur.com/kycqKnu
  • Dont ask me how, but I got it working.
  • hey ive got same issue - how did you fix it?
  • You might check your OS version. I've had a consistent trouble with older OS X versions (older than 10.8).

    The manual also has a note that I've found helpful before:

    Q: I got an error during uploading: "CreateProcess error=14001"
    A: Some required libraries are missing on your system. You need to install Microsoft Visual C++ 2008 x86
    redistributable: http://www.microsoft.com/en-us/download/details.aspx?id=5582
  • You should also make sure that your Bluetooth module is set to even parity, as the board will not upgrade firmware using no parity per the manual.