EN RU CN
Gimbal will not stablize
  • Hi,
    I have the ARMBCG V2 board. Hooked up ok, power is good, and the current firmware is loaded.

    In the gui, I cannot get the auto-detect for the poles to work. I manually set them to 14, as I am using the iFlight motors.

    No matter what I do to set parameters, the gimbal will not settle down from shaking, and it does not react at all to moving the gimbal. So no stabilization. I am also getting fast flashing orange and green leds. Error code only shows 12C=0

    Any advice?
    Thanks
  • I received my bgc from armbgc.com and I'm having similar issues I get no readings in the GUI at all. But I can see that the second led flashes while connected via USB along with the main led flashing rapidly. I have successfully flashed the fw both with the newest and oldest along with the GUIs.
    If I just power the assembled gimbal from a battery the controller goes thru the startup then flashes slow like its calibrating, then right to the rapid flash........ Very annoying, I was excited to have a semi inexpensive gimbal but I'm fearing the worst. I get the same in the GUI for the error code, but I think that just means there is no error code. I could be totally wrong....
  • I should add that all the other parameters react when adjusted, but whatever they are, it dances around with a violence proportional to the settings. Only the auto-pole count seems non-functional.

    Agreed on the error code, I think?. No error shown, but leds flash fast.
  • If it is low freaquency oscilation try increasing "D" till it stops.
    If it is a high freaquecy oscilation lower "P" till it stops.
    How do you know if its high or low oscilations?
    High fells like a vibrator.
    Low will be visually shaking.
  • got the same armbgc. only rapid flash no readings at all and no motor movement (xcept during calibration)
  • GOT IT! got the FTDI 2.8.14 from ARMBGC now it works!
  • Thanks m8 ! it connects now
  • I´m on a win 64 bit computer and this driver worked for me:
    http://www.silabs.com/products/mcu/pages/usbtouartbridgevcpdrivers.aspx
    Good luck