EN RU CN
Losing follow ya during yaw with pitch???
  • I have just installed a 32bit board on my dys 3axis gopro gimbal. I ran auto tune and was getting very smooth results. But I have found a problem. I can yaw while the copter is flat without issues. But when I ya while the copter is pitched or rolled my yaw axis will slip and the yaw will be off. I started moving the gimbal in my hands and found that my roll can easily lose its hold by tiling to copter more than 10 degrees. I have tried increasing my power and my P setting but am not having any better results. Could anyone offer me some advise?

    Here are my PID settings

    http://i.imgur.com/JdFxmpT.png

    http://i.imgur.com/HFEEz5t.png
  • Here is an example video.

  • Here is an example of how the yaw fails. Pitch seems ok and yaw seems ok. But when i roll the yaw slips. http://youtu.be/aq-0h8RuzIQ
  • Could the problem be related to how my imu is mounted? When I replaced my 8bit board with the 32 bit I had to make a little adapter to hold the imu. The imu is now not perfectly aligned with any certain axis. It would be impossible to put the IMU in the center of all axis as it would have to be inside the camera.
  • Your power is low, how high is the voltage, with the Tarot gimbal parts I am using inverter and running the gimbal at 9 V. This will not though solve your problem.

    Are you sure the inverted status is correct, has it been set wit the Auto function?

    Is this with 1 IMU? Try activating 'estimate frame angles from motors' and perform follow/offset/auto
  • I am running a 4s battery in my copter, the gimbal is running off a 12v bec.

    I am not positive the inverted status is correct. That is what the auto function gave me. I have tried it non inverted as well but that does not fix the issue.

    This is with 2 imu's. One for the frame and one on the camera.

    I will try the estimate frame angles.
  • Estimate frame angles mentions "use this on handheld only!" Is that of concern for aerial use?
  • With 2 IMUs you should not need it. If you are running 12 V maybe you could set more power. Just check the motors frequently after rising over to make sure they do not over heat.

    When the motor power is ok, the motor auto gives the inverted status correctly.

    Also make sure your gimbal is balanced, also the yaw axis.

    It probably would be good to perform the hole setup carefully from the start carefully following the users manual.
  • Raising the motor power made the motor get hot quickly and after doing an autotune with 200 power the problem was still present. However I lowered the power back down to 100 while still keeping the pid's I had from autotune at 200 power and the problem is now gone. I will try a flight and see if the stabilization is good. But this leads me to believe that the problem was not the power but the pids.
  • Do you use good stability setting when auto tuning? If the gimbal does not tune well on good stability setting, then quite possibly there is some mechanical problems like loose play or binding.

    But sometimes it is just necessary to lower the PID values from the Auto tune results. This is effectively what you have done, as higher Power will result lower PID. Anyway good if it is working now.
  • I have the slider set at the default position in the middle between good stability and good precision. There is no mechanical problem I have checked that everything is tight, balanced, and unbinding.

    I think that could be the problem is that autotune was just giving me to high of pids. I will do some testing today and see how it goes.
  • Here are my pids after autotune at 200 power and then lowering power back to 100.

    http://i.imgur.com/v8zEfPS.png