EN RU CN
setting up a Mac
  • I have a Mac and i'm trying to get it set up to flash my V3.11 board I've downloaded the GUI, I've installed the COM driver and i have installed the MacPorts thingy. in the user SimpleGBC manual it says to "copy dfu-util to “SimpleBGC_GUI/bin/dfu-util-mac” to let GUI to find and execute it"
    1. what do they mean by copy? literally copy the dfu folder and all it's contents?
    2. there is no "SimpleBGC_GUI/bin/dfu-util-mac" anywhere that searchlight can find.
  • Are you using firmware 2.42b7 or higher ?
    (GUI) Firmware upgrade now works under Mac OS and Linux (see User manual for details)

    If I'm looking in the 2.43b9 GUI folder and open the BIN folder "SimpleBGC_GUI_2_43b9\bin", I see a file with the name "dfu-util-mac" !
    And please check the "help" folder, which you can also find in the GUI folder !
  • i am using 2.43b9. Yes i see it too. funny that searchlight didn't find it. so what do i do now. do i need to copy the dfu-util? or am i good to go?
  • I tried connecting again, but i get an error. "unexpected error: java.io.IOException: limit reached!"
    what does that mean? it also says that the firmaware is 0.53 b4 and that i need to upgrade. but i can't do that through the GUI because it won't connect!
  • I can't check it now for you.
    Normally I'm using my windows platform.

    Have you checked this:
    GUI for MAC OS:
    • Run SimpleBGC_GUI.jar
    ATTENTION: GUI uses a virtual COM port. Create a lock file to access it.:
    1. Start terminal (navigate to /Applications/Utilities and double click on Terminal)
    2. Make folder "/var/lock" by command: sudo mkdir /var/lock
    3. Change permissions by command: sudo chmod 777 /var/lock
    4. Allow to run non-signed applications in System Preferences > Security & Privacy > General > Allow
    Applications downloaded from: Anywhere

    And this:
    Upgrading under Mac OS and Linux
    Starting from 2.42b7, its possible to upgrade firmware from GUI under Mac OS and Linux (and virtually, any
    other OS). Open-source tool stm32ld (https://github.com/jsnyder/stm32ld) is used to upload firmware to the
    board.
    NOTE: If its failed to run tool under your OS, you can compile it from sources (located in the
    'SimpleBGC_GUI/bin/stm32ld-src' folder). Place a result to the 'SimpleBGC_GUI/bin' folder, renaming it to
    'stm32ld_mac' for Mac OS, 'stm32ld_linux' for Linux family, and 'stm32ld' for any other OS.

    And is your Java up to date ?
    To start the application you need to have Java Runtime Environment by Oracle in your system: http://www.java.com

    I've checked the manual and see that the DFU driver is only needed for the Tiny Board !

    Good luck... :-)
  • I have the GUI installed and created the folder and changed permissions. i also just updated Java so maybe that was it, i'll try later today. i went to the link for the uploader and it's an Arduino file i see. i have Arduino compiler, is that the same thing? all i need is some instructions of what to do. I know how to connect the board and flash it but still a bit unsure of where to get the sketch.
  • I feel like an idiot, but where do i find the firmware? when i go to the download page i see GUI and manual downloads but no firmware.
  • At this moment I don't have my Macbook with me.
    Next Monday I will give it a try and see what happens during the upload.

    The files for the uploader are not Arduino files !
    And all these files are all ready in the GUI Bin folder.

    About the firmware, this will be normally downloaded via de GUI !
    And can be found in the GUI folder "SimpleBGC_GUI_2_43b9\firmware"
    For the uploader you don't need the .hex file !

    Which OS X are you running at ?
  • i'm on 10.9. i guess if i could connect to the gui i might be able to flash. i'll try tomorrow now that i've updated Java
  • ok. it still wont connect. still going on about Java, but i have updated it. and it says i have different versions of firmware and GUI. so i need to upgrade the firmware first, but when i go to the link with the stm32ld uploader, it has no instructions at all. i have no idea what to do with it.
  • ok, i am a dolt. turns out to be an 8bit board. i wish there was a way to tell. so it still will not upload. i get an error that says "cannot run program /blah/blah/SimpleBGC_GUI_2_40/bin/arvdude": error=2, no such file or directory. i have downloaded the GUI 2.40, and downloaded the firmware 2.4 since it was not in the GUI folder. I have put it in the firmware folder, no go. i put it in the Arvdude folder, no go. when i brows for the firmware i can find it and select it so why does it say it's not found?
  • i am really getting frustrated here. the site says that mac users can upload using arvdude but there is no files in there that run on mac! only .exe
  • ok. i have gotten somewhere. i now have connected to it with GUI 2.2b2 and that is the firmware. i cannot connect with 2.3 i tried ti upgrade to 2.3 using the 2.2 GUI, no go. so we're back to square 1. how do i upgrade if i can't connect past the version that i have?!